Jump to content

Is Demo Smoother broken?

Recommended Posts

I was ready to start shooting Little Freemans - Episode 3 when, surprise, surprise, the Demo Smoother decided piss me off from shot 1. I've been trying to record a camera path I created with the Smoother but it recorded a weird path running from the origin of the map to the info_player_start entity. It ignored my custom path completely and jumped around the other path. And, of course, I was standing still while recording the demo, shame on you for even thinking I wasn't.


Anyone knows what's going on? I'm using Source 2009, HL Episode One and also tested on Episode Two with the same results. If no one has encountered this problem so far, could someone run a quick Smoother test and let me know if they have the same problem? Thanks!

Share this post

Link to post

Yes, demo smoother is partially broken, however your particular problem sounds like you're doing something incorrectly. Here's a quick test off the top of my head:


1. Type in the number of ticks in the fields (from 1 or 0 to whatever number the demo it ends at)

2. Hit reload / revert some combination of these a couple times until it loads

3. In Drive mode, float around somewhere you want the to be

4. Go to to a low number tick, like 5 in demo smoother (not in the demo itself, that won't matter)

5. Make a keyframe

6. float somewhere else you want to be in drive mode, say tick 500, it doesn't matter, just a few seconds away at least

7. Make another keyframe

8. Press Process / Splines origin, then Process / splines angles all (I think, this is from memory)

9. Turn drive mode off and play the sequence back in demosmoother. If it looks like it remotely works, press SAVE and try playing back the new demo.


Your description sounds like you might be getting your tick numbers wrong or doing something wrong on #8, but it's hard to tell.

Share this post

Link to post

That's the workflow I'm using so I'm not doing anything wrong.


I'm able to create my custom path, represented by two green cubes connected by a green line. The other path is also present as a white line running from the origin of the map to the info_player_start entity. The curious thing is, when I process the splines, it is the weird path that get's processed and not the one I created. Maybe that makes some sense to you.


It's a good thing I can work on other things in the mean time. I only hope that by the time I finish phoneme extraction, flexes, map editing, lighting and shooting static shots, Valve will have already fixed the Demo Smoother and broken something else instead. Otherwise, I'll just be forces to find some unothodox solution to camera tracking.

Share this post

Link to post

I can't really pinpoint what's going wrong from your description. You might want to consider making a fraps video of you going through the process and I could probably identify it then.

Share this post

Link to post

I started the recording and redone everything the same way as before only this time it worked... I'm guessing they either fixed it or Fraps fixed it. With Valve, I'm not susprised anymore...


The white line running from the origin of the map to the info_player_start entity is still there but it's harmless now. Let's hope it will not rise to power again...

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in the community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.